Drupal Sistem Gereksinimleri

Hata mesajı

Deprecated function: book_prev() (/var/www/html/drupalturkiye.org/modules/book/book.module dosyasının 775 satırı) içinde The each() function is deprecated. This message will be suppressed on further calls.

Drupal'ı kurmak ve çalıştırmak için web sunucunuzun belli asgari gereksinimleri karşılaması gerekmektedir. Ancak çoğu hosting şirketinin en alt düzeydeki planları/paketleri bile bu "asgari gereksinimler"i karşılamaktadır. Bu gereksinimler şöyle sıralanabilir:

Disk Alanı

Minimum kurulum 15 megabyte gerektirir. Çok sayıda topluluk eklentisi ve teması kullanan bir site için 60 megabyte kadar bir alan gerekebilir. Alan gereksinimini hesaplarken veritabanı, yönetici ve kullanıcılar tarafından yüklenen dosyalar, yedekler ve diğer dosyaları da dikkate almalısınız.

Web Sunucusu

Apache, Nginx ya da Microsoft IIS
Web sunucusu gereksinimleri hakkında ayrıntılar(İngilizce - Drupal.org).

Veritabanı

Drupal 6: MySQL 4.1 ya da üstü, PostgreSQL 7.1
Drupal 7: MySQL 5.0.15 ya da üstü(PDO ile), PostgreSQL 8.3 ya da üstü(PDO ile), SQLite 3.3.7 ya da üstü
Microsoft SQL Server ve Oracle da ek eklentilerle desteklenmektedir.
Veritabanı gereksinimleri hakkında ayrıntılar(İngilizce - Drupal.org).

PHP

Drupal 6: PHP 4.4.0 ya da üstü (5.2 önerilir).
Drupal 7: PHP 5.2.5 ya da üstü (5.3 önerilir).
Drupal 8: PHP 5.3.10 ya da üstü.

PHP gereksinimleri hakkında ayrıntılı bilgi(İngilizce - Drupal.org).